about summary refs log tree commit homepage
path: root/Makefile.am
diff options
context:
space:
mode:
authorEric Wong <e@80x24.org>2014-05-22 22:11:13 +0000
committerEric Wong <e@80x24.org>2014-05-22 22:44:31 +0000
commit6189377b88318c5cc53bbfd0ec7983a0a396253b (patch)
tree7f9936eb06d475abb8d610ee2eaa44e3b7c72e9d /Makefile.am
parentcd7b4cbacbc968bd4d7ed5fed9122f75d229793c (diff)
downloadcmogstored-6189377b88318c5cc53bbfd0ec7983a0a396253b.tar.gz
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am17
1 files changed, 15 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 9fb61cd..0d1f29a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -94,12 +94,25 @@ mog_src += util.h
 mog_src += upgrade.c
 mog_src += yield.c
 
-LDADD = $(LIBINTL) $(top_builddir)/lib/libgnu.a libnostd.a $(LIB_CLOCK_GETTIME)
-noinst_LIBRARIES = libnostd.a
+noinst_LIBRARIES = libnostd.a libccan.a
+LDADD = $(LIBINTL) $(top_builddir)/lib/libgnu.a \
+        $(noinst_LIBRARIES) $(LIB_CLOCK_GETTIME)
+
 nostd_include = -include $(top_builddir)/$(CONFIG_HEADER)
 libnostd_a_SOURCES = nostd/setproctitle.c nostd/setproctitle_noop.c
 libnostd_a_CFLAGS = $(AM_CFLAGS) $(nostd_include) $(NOSTD_CFLAGS)
 
+ccan_src =
+ccan_src += ccan/check_type/check_type.h
+ccan_src += ccan/container_of/container_of.h
+ccan_src += ccan/str/str.h
+ccan_src += ccan/str/str_debug.h
+ccan_src += ccan/str/str.c
+ccan_src += ccan/str/debug.c
+ccan_src += ccan/build_assert/build_assert.h
+ccan_src += ccan/list/list.h
+libccan_a_SOURCES = $(ccan_src)
+
 RLFLAGS = -G2 -e
 RAGEL = ragel
 RL_MAIN = cfg_parser.rl iostat_parser.rl listen_parser.rl mgmt_parser.rl \