about summary refs log tree commit homepage
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index adb37f3..7194216 100644
--- a/configure.ac
+++ b/configure.ac
@@ -36,6 +36,9 @@ dnl gnulib *at functions aren't thread-safe, ask for the real thing
 AC_CHECK_FUNCS([openat renameat mkdirat fstatat unlinkat])
 
 AC_CHECK_FUNCS([epoll_wait epoll_pwait ppoll])
+AC_CHECK_FUNCS([epoll_ctl], [HAVE_EPOLL=1], [HAVE_EPOLL=0])
+AC_SUBST(HAVE_EPOLL)
+AM_CONDITIONAL(HAVE_EPOLL, test "x$HAVE_EPOLL" = "x1")
 
 dnl libkqueue should work in the future
 AC_CHECK_FUNCS([kqueue])
@@ -45,6 +48,9 @@ AC_CHECK_FUNCS([sendfile])
 AC_CHECK_FUNCS([open_memstream])
 AC_CHECK_FUNCS([posix_fadvise])
 
+dnl non-standard, but common
+AC_CHECK_FUNCS([pthread_yield])
+
 dnl gnulib doesn't actually define SOCK_NONBLOCK/SOCK_CLOEXEC, and
 dnl even if it did, emulation wouldn't be thread-safe
 AC_CHECK_FUNCS([accept4])
@@ -61,5 +67,8 @@ case $build_os in
 esac
 ])
 
+CM_SYSTEMTAP
+CM_LD_WRAP
+
 AC_CONFIG_FILES([Makefile lib/Makefile])
 AC_OUTPUT