From mboxrd@z Thu Jan 1 00:00:00 1970 From: Pablo de Lara Subject: [PATCH v4 0/6] update jhash function Date: Tue, 12 May 2015 12:02:32 +0100 Message-ID: <1431428560-25426-1-git-send-email-pablo.de.lara.guarch@intel.com> References: <1430837034-21031-1-git-send-email-pablo.de.lara.guarch@intel.com> To: dev@dpdk.org Return-path: Received: from mga11.intel.com (mga11.intel.com [192.55.52.93]) by dpdk.org (Postfix) with ESMTP id E72FB376C for ; Tue, 12 May 2015 13:03:06 +0200 (CEST) In-Reply-To: <1430837034-21031-1-git-send-email-pablo.de.lara.guarch@intel.com> List-Id: patches and discussions about DPDK List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Errors-To: dev-bounces@dpdk.org Sender: "dev" Jenkins hash function was developed originally in 1996, and was integrated in first versions of DPDK. The function has been improved in 2006, achieving up to 60% better performance, compared to the original one. This patchset updates the current jhash in DPDK, including two new functions that generate two hashes from a single key. It also separates the existing hash function performance tests to another file, to make it quicker to run. changes in v4: - Simplify key alignment checks - Include missing x86 arch check changes in v3: - Update rte_jhash_1word, rte_jhash_2words and rte_jhash_3words functions changes in v2: - Split single commit in three commits, one that updates the existing functions and another that adds two new functions and use one of those functions as a base to be called by the other ones. - Remove some unnecessary ifdefs in the code. - Add new macros to help on the reutilization of constants - Separate hash function performance tests to another file and improve cycle measurements. - Rename existing function rte_jhash2 to rte_jhash_32b (something more meaninful) and mark rte_jhash2 as deprecated Pablo de Lara (6): test/hash: move hash function perf tests to separate file test/hash: improve accuracy on cycle measurements hash: update jhash function with the latest available hash: add two new functions to jhash library hash: remove duplicated code hash: rename rte_jhash2 to rte_jhash_32b app/test/Makefile | 1 + app/test/test_func_reentrancy.c | 2 +- app/test/test_hash.c | 4 +- app/test/test_hash_func_perf.c | 145 +++++++++++++++++ app/test/test_hash_perf.c | 71 +-------- lib/librte_hash/rte_jhash.h | 338 +++++++++++++++++++++++++++++---------- 6 files changed, 402 insertions(+), 159 deletions(-) create mode 100644 app/test/test_hash_func_perf.c -- 1.7.4.1