From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1757245AbbFQP2G (ORCPT ); Wed, 17 Jun 2015 11:28:06 -0400 Received: from e37.co.us.ibm.com ([32.97.110.158]:39391 "EHLO e37.co.us.ibm.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1755401AbbFQP2D (ORCPT ); Wed, 17 Jun 2015 11:28:03 -0400 X-Helo: d03dlp02.boulder.ibm.com X-MailFrom: paulmck@linux.vnet.ibm.com X-RcptTo: linux-kernel@vger.kernel.org Date: Wed, 17 Jun 2015 08:27:56 -0700 From: "Paul E. McKenney" To: Ingo Molnar Cc: Andy Lutomirski , x86@kernel.org, linux-kernel@vger.kernel.org, =?iso-8859-1?Q?Fr=E9d=E9ric?= Weisbecker , Rik van Riel , Oleg Nesterov , Denys Vlasenko , Borislav Petkov , Kees Cook , Brian Gerst Subject: Re: [RFC/INCOMPLETE 01/13] context_tracking: Add context_tracking_assert_state Message-ID: <20150617152756.GA3913@linux.vnet.ibm.com> Reply-To: paulmck@linux.vnet.ibm.com References: <1d95640676a92a5ff7382e9c87517c12ea23ccd9.1434485184.git.luto@kernel.org> <20150617094114.GA3940@gmail.com> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <20150617094114.GA3940@gmail.com> User-Agent: Mutt/1.5.21 (2010-09-15) X-TM-AS-MML: disable X-Content-Scanned: Fidelis XPS MAILER x-cbid: 15061715-0025-0000-0000-00000BAFD601 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Wed, Jun 17, 2015 at 11:41:14AM +0200, Ingo Molnar wrote: > > * Andy Lutomirski wrote: > > > This will let us sprinkle sanity checks around the kernel without > > making too much of a mess. > > > > Signed-off-by: Andy Lutomirski > > --- > > include/linux/context_tracking.h | 8 ++++++++ > > 1 file changed, 8 insertions(+) > > > > diff --git a/include/linux/context_tracking.h b/include/linux/context_tracking.h > > index 2821838256b4..0fbea4b152e1 100644 > > --- a/include/linux/context_tracking.h > > +++ b/include/linux/context_tracking.h > > @@ -57,6 +57,13 @@ static inline void context_tracking_task_switch(struct task_struct *prev, > > if (context_tracking_is_enabled()) > > __context_tracking_task_switch(prev, next); > > } > > + > > +static inline void context_tracking_assert_state(enum ctx_state state) > > +{ > > + rcu_lockdep_assert(!context_tracking_is_enabled() || > > + this_cpu_read(context_tracking.state) == state, > > + "context tracking state was wrong"); > > +} > > Please don't introduce assert() style debug check interfaces! > > (And RCU should be fixed too I suspect.) The thought is to rename rcu_lockdep_assert() to RCU_LOCKDEP_WARN() by analogy to WARN()? Easy to do if so! Or am I missing the point? Thanx, Paul > They are absolutely horrible on the brain when mixed with WARN_ON() interfaces, > which are the dominant runtime check interface in the kernel. > > Instead make it something like: > > #define ct_state() (this_cpu_read(context_tracking.state)) > > #define CT_WARN_ON(cond) \ > WARN_ON(context_tracking_is_enabled() && (cond)) > > and then the debug checks can be written as: > > CT_WARN_ON(ct_state() != CONTEXT_KERNEL); > > This is IMHO _far_ more readable than: > > context_tracking_assert_state(CONTEXT_KERNEL); > > ok? > > (Assuming people will accept 'ct/CT' as an abbreviation for context tracking.) > > Thanks, > > Ingo >