From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S932597AbcCKQ2N (ORCPT ); Fri, 11 Mar 2016 11:28:13 -0500 Received: from mga03.intel.com ([134.134.136.65]:34690 "EHLO mga03.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S932264AbcCKQ2L (ORCPT ); Fri, 11 Mar 2016 11:28:11 -0500 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.24,321,1455004800"; d="scan'208";a="931849243" Date: Fri, 11 Mar 2016 22:02:21 +0530 From: Vinod Koul To: Sinan Kaya Cc: dmaengine@vger.kernel.org, marc.zyngier@arm.com, mark.rutland@arm.com, timur@codeaurora.org, devicetree@vger.kernel.org, cov@codeaurora.org, jcm@redhat.com, shankerd@codeaurora.org, vikrams@codeaurora.org, eric.auger@linaro.org, agross@codeaurora.org, arnd@arndb.de, linux-arm-msm@vger.kernel.org, linux-arm-kernel@lists.infradead.org, linux-kernel@vger.kernel.org Subject: Re: [PATCH V14 5/9] dma: qcom_hidma: implement lower level hardware interface Message-ID: <20160311163221.GC13211@localhost> References: <1454646882-24369-1-git-send-email-okaya@codeaurora.org> <1454646882-24369-6-git-send-email-okaya@codeaurora.org> <20160311020650.GG11154@localhost> <56E2EC1C.6040107@codeaurora.org> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: <56E2EC1C.6040107@codeaurora.org> User-Agent: Mutt/1.5.21 (2010-09-15) Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Fri, Mar 11, 2016 at 11:02:36AM -0500, Sinan Kaya wrote: > > These are rest here are not namespace properly... > > If I understood it right, you want me to prefix them with as HIDMA_xyz. > Correct? Yes.. > >> + /* copy the TRE into its location in the TRE ring */ > >> + spin_lock_irqsave(&lldev->lock, flags); > >> + tre->tre_index = lldev->tre_write_offset / TRE_SIZE; > >> + lldev->pending_tre_list[tre->tre_index] = tre; > >> + memcpy(lldev->tre_ring + lldev->tre_write_offset, &tre->tre_local[0], > >> + TRE_SIZE); This one > >> + lldev->tx_status_list[tre->idx].err_code = 0; > >> + lldev->tx_status_list[tre->idx].err_info = 0; > >> + tre->queued = 1; > >> + lldev->pending_tre_count++; > > Is this the only one without alignment? I couldn't understand what you mean by > above one? quoting Coding Style: Statements longer than 80 columns will be broken into sensible chunks, unless exceeding 80 columns significantly increases readability and does not hide information. Descendants are always substantially shorter than the parent and are placed substantially to the right. > > >> + lldev->tre_write_offset = (lldev->tre_write_offset + TRE_SIZE) > >> + % lldev->tre_ring_size; > > > > These and above one should be right justfied per coding style -- ~Vinod