From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1751036AbcBAXC5 (ORCPT ); Mon, 1 Feb 2016 18:02:57 -0500 Received: from foss.arm.com ([217.140.101.70]:52246 "EHLO foss.arm.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1750900AbcBAXCy (ORCPT ); Mon, 1 Feb 2016 18:02:54 -0500 From: =?UTF-8?Q?Andr=c3=a9_Przywara?= Subject: Re: [linux-sunxi] Re: [PATCH 05/11] drivers: pinctrl: add driver for Allwinner A64 SoC To: Karsten Merker , Maxime Ripard , Chen-Yu Tsai , linux-sunxi@googlegroups.com, Arnd Bergmann , linux-arm-kernel@lists.infradead.org, linux-kernel@vger.kernel.org, Linus Walleij , Vishnu Patekar , linux-gpio@vger.kernel.org, Rob Herring , Pawel Moll , Mark Rutland , Ian Campbell , Kumar Gala , devicetree@vger.kernel.org References: <1454348370-3816-1-git-send-email-andre.przywara@arm.com> <1454348370-3816-6-git-send-email-andre.przywara@arm.com> <20160201182754.GA14737@excalibur.cnev.de> <20160201184505.GB14737@excalibur.cnev.de> Organization: ARM Ltd. Message-ID: <56AFE3F7.6050204@arm.com> Date: Mon, 1 Feb 2016 23:02:15 +0000 User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Thunderbird/38.4.0 MIME-Version: 1.0 In-Reply-To: <20160201184505.GB14737@excalibur.cnev.de> Content-Type: text/plain; charset=utf-8 Content-Transfer-Encoding: 7bit Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On 01/02/16 18:45, Karsten Merker wrote: > Hello, > > I by mistake pressed "send" on my previous mail when I intended > to further edit it, so here comes a followup. > I definitely need more coffee ;-). Or less? ;-) vvvvvvvvvv Thinking of twitchy fingers... > On Mon, Feb 01, 2016 at 07:27:54PM +0100, Karsten Merker wrote: >> On Mon, Feb 01, 2016 at 05:39:24PM +0000, Andre Przywara wrote: > >>> +static const struct sunxi_pinctrl_desc a64_pinctrl_data = { >>> + .pins = a64_pins, >>> + .npins = ARRAY_SIZE(a64_pins), >>> + .irq_banks = 3, >>> +}; >>> + >>> +static int a64_pinctrl_probe(struct platform_device *pdev) >>> +{ >>> + return sunxi_pinctrl_init(pdev, >>> + &a64_pinctrl_data); >>> +} >>> + >>> +static const struct of_device_id a64_pinctrl_match[] = { >>> + { .compatible = "allwinner,a64-pinctrl", }, > > s/allwinner,a64-pinctrl/allwinner,sun50i-a64-pinctrl/ ? As mentioned in the other mail, allwinner should be enough to make the naming unique. Especially as this is about DT namings, which should be valid outside of the Linux world even. Cheers, Andre. > >>> + {} >>> +}; >>> +MODULE_DEVICE_TABLE(of, a64_pinctrl_match); >>> + >>> +static struct platform_driver a64_pinctrl_driver = { >>> + .probe = a64_pinctrl_probe, >>> + .driver = { >>> + .name = "a64-pinctrl", >>> + .of_match_table = a64_pinctrl_match, >>> + }, >>> +}; >>> +module_platform_driver(a64_pinctrl_driver); >>> + >>> +MODULE_AUTHOR("Andre Przywara "); >>> +MODULE_DESCRIPTION("Allwinner A64 pinctrl driver"); >>> +MODULE_LICENSE("GPL"); >> >> For the above function names one could also think about using the > > s/function names/variable definitions/ > >> existing naming scheme including the SoC family as we do in the >> other sunxi pinctrl drivers, but as they are only internal to the >> driver, that would really just be a matter of cosmetics :-). > > Regards, > Karsten >