From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1754797AbcB2CDO (ORCPT ); Sun, 28 Feb 2016 21:03:14 -0500 Received: from szxga01-in.huawei.com ([58.251.152.64]:58716 "EHLO szxga01-in.huawei.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1752578AbcB2CDL (ORCPT ); Sun, 28 Feb 2016 21:03:11 -0500 Message-ID: <56D3A6BC.8020005@huawei.com> Date: Mon, 29 Feb 2016 10:02:36 +0800 From: Shannon Zhao User-Agent: Mozilla/5.0 (Windows NT 6.1; rv:24.0) Gecko/20100101 Thunderbird/24.4.0 MIME-Version: 1.0 To: "Rafael J. Wysocki" , Stefano Stabellini CC: "Rafael J. Wysocki" , "linux-arm-kernel@lists.infradead.org" , , , , Catalin Marinas , Will Deacon , Mark Rutland , , , "devicetree@vger.kernel.org" , , Linux Kernel Mailing List , , Shannon Zhao , , Len Brown , open list: ACPI , ; Illegal-Object: Syntax error in CC: address found on vger.kernel.org: CC: ; ^-missing semicolon to end mail group, extraneous tokens in mailbox, missing end of mailbox Subject: Re: [PATCH v4 01/17] Xen: ACPI: Hide UART used by Xen References: <1454641552-12576-1-git-send-email-zhaoshenglong@huawei.com> <44113385.2QnPtvxQx0@vostro.rjw.lan> <1667812.hY9vsC2epc@vostro.rjw.lan> In-Reply-To: <1667812.hY9vsC2epc@vostro.rjw.lan> Content-Type: text/plain; charset="UTF-8" Content-Transfer-Encoding: 7bit X-Originating-IP: [10.177.16.142] X-CFilter-Loop: Reflected X-Mirapoint-Virus-RAPID-Raw: score=unknown(0), refid=str=0001.0A020202.56D3A6CF.000E,ss=1,re=0.000,recu=0.000,reip=0.000,cl=1,cld=1,fgs=0, ip=0.0.0.0, so=2013-06-18 04:22:30, dmn=2013-03-21 17:37:32 X-Mirapoint-Loop-Id: 996af2fd873397c172419cd1ccc817e6 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On 2016/2/12 6:22, Rafael J. Wysocki wrote: > On Thursday, February 11, 2016 04:04:14 PM Stefano Stabellini wrote: >> > On Wed, 10 Feb 2016, Rafael J. Wysocki wrote: >>> > > On Tuesday, February 09, 2016 11:19:02 AM Stefano Stabellini wrote: >>>> > > > On Mon, 8 Feb 2016, Rafael J. Wysocki wrote: >>>>> > > > > On Monday, February 08, 2016 10:57:01 AM Stefano Stabellini wrote: >>>>>> > > > > > On Sat, 6 Feb 2016, Rafael J. Wysocki wrote: >>>>>>> > > > > > > On Fri, Feb 5, 2016 at 4:05 AM, Shannon Zhao wrote: >>>>>>>> > > > > > > > From: Shannon Zhao >>>>>>>> > > > > > > > >>>>>>>> > > > > > > > ACPI 6.0 introduces a new table STAO to list the devices which are used >>>>>>>> > > > > > > > by Xen and can't be used by Dom0. On Xen virtual platforms, the physical >>>>>>>> > > > > > > > UART is used by Xen. So here it hides UART from Dom0. >>>>>>>> > > > > > > > >>>>>>>> > > > > > > > Signed-off-by: Shannon Zhao >>>>>>>> > > > > > > > Reviewed-by: Stefano Stabellini >>>>>>> > > > > > > >>>>>>> > > > > > > Well, this doesn't look right to me. >>>>>>> > > > > > > >>>>>>> > > > > > > We need to find a nicer way to achieve what you want. >>>>>> > > > > > >>>>>> > > > > > I take that you are talking about how to honor the STAO table in Linux. >>>>>> > > > > > Do you have any concrete suggestions? >>>>> > > > > >>>>> > > > > I do. >>>>> > > > > >>>>> > > > > The last hunk of the patch is likely what it needs to be, although I'm >>>>> > > > > not sure if the place it is added to is the right one. That's a minor thing, >>>>> > > > > though. >>>>> > > > > >>>>> > > > > The other part is problematic. Not that as it doesn't work, but because of >>>>> > > > > how it works. With these changes the device will be visible to the OS (in >>>>> > > > > fact to user space even), but will never be "present". I'm not sure if >>>>> > > > > that's what you want? >>>>> > > > > >>>>> > > > > It might be better to add a check to acpi_bus_type_and_status() that will >>>>> > > > > evaluate the "should ignore?" thing and return -ENODEV if this is true. This >>>>> > > > > way the device won't be visible at all. >>>> > > > >>>> > > > Something like below? Actually your suggestion is better, thank you! >>>> > > > >>>> > > > diff --git a/drivers/acpi/scan.c b/drivers/acpi/scan.c >>>> > > > index 78d5f02..4778c51 100644 >>>> > > > --- a/drivers/acpi/scan.c >>>> > > > +++ b/drivers/acpi/scan.c >>>> > > > @@ -1455,6 +1455,9 @@ static int acpi_bus_type_and_status(acpi_handle handle, int *type, >>>> > > > if (ACPI_FAILURE(status)) >>>> > > > return -ENODEV; >>>> > > > >>>> > > > + if (acpi_check_device_is_ignored(handle)) >>>> > > > + return -ENODEV; >>>> > > > + >>>> > > > switch (acpi_type) { >>>> > > > case ACPI_TYPE_ANY: /* for ACPI_ROOT_OBJECT */ >>>> > > > case ACPI_TYPE_DEVICE: >>>> > > > >>> > > >>> > > I thought about doing that under ACPI_TYPE_DEVICE, because it shouldn't be >>> > > applicable to the other types. But generally, yes. >> > >> > I was pondering about it myself. Maybe an ACPI_TYPE_PROCESSOR object >> > could theoretically be hidden with the STAO? > But this patch won't check for it anyway, will it? > > It seems to be only checking against the UART address or have I missed > anything? > >> > I added the check before >> > the switch because I thought that there would be no harm in being >> > caution about it. >> > >> > >>> > > Plus I'd move the table checks to acpi_scan_init(), so the UART address can >>> > > be a static variable in scan.c. >>> > > >>> > > Also maybe rename acpi_check_device_is_ignored() to something like >>> > > acpi_device_should_be_hidden(). >> > >> > Both make sense. Shannon, are you happy to make these changes? > Plus maybe make acpi_device_should_be_hidden() print a (KERN_INFO) message > when it decides to hide something? Ok, will update this patch. Thanks a lot! -- Shannon