LKML Archive mirror
 help / color / mirror / Atom feed
* [PATCH v2 0/5] Staging: panel: TODO fixes
@ 2016-01-03 19:38 Ksenija Stanojevic
  2016-01-03 19:39 ` [PATCH v2 1/5] Staging: panel: Use u8 type Ksenija Stanojevic
                   ` (4 more replies)
  0 siblings, 5 replies; 6+ messages in thread
From: Ksenija Stanojevic @ 2016-01-03 19:38 UTC (permalink / raw
  To: gregkh; +Cc: willy, devel, linux-kernel, Ksenija Stanojevic

This patchset is based on checkpatch fixes made by previous patches.
Here I tried to address all suggestions made by Dan and Willy.

Signed-off-by: Ksenija Stanojevic <ksenija.stanojevic@gmail.com>

Ksenija Stanojevic (5):
  Staging: panel: Use u8 type
  Staging: panel: Remove typedef pmask_t
  Staging: panel: Remove ULL
  Staging: panel: Reduce value range for *name
  Staging: panel: Make statement more readable

 drivers/staging/panel/panel.c | 46 +++++++++++++++++++++----------------------
 1 file changed, 22 insertions(+), 24 deletions(-)

-- 
1.9.1


^ permalink raw reply	[flat|nested] 6+ messages in thread

* [PATCH v2 1/5] Staging: panel: Use u8 type
  2016-01-03 19:38 [PATCH v2 0/5] Staging: panel: TODO fixes Ksenija Stanojevic
@ 2016-01-03 19:39 ` Ksenija Stanojevic
  2016-01-03 19:40 ` [PATCH v2 2/5] Staging: panel: Remove typedef pmask_t Ksenija Stanojevic
                   ` (3 subsequent siblings)
  4 siblings, 0 replies; 6+ messages in thread
From: Ksenija Stanojevic @ 2016-01-03 19:39 UTC (permalink / raw
  To: gregkh; +Cc: willy, devel, linux-kernel, Ksenija Stanojevic

Declare om, im, omask and imask as u8 to remove any confusion if
that describes the 8 bits of the data bus on the parallel port.
Also change return type of lcd_write_data() to u8.

Signed-off-by: Ksenija Stanojevic <ksenija.stanojevic@gmail.com>
---
v2: nothing

 drivers/staging/panel/panel.c | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/drivers/staging/panel/panel.c b/drivers/staging/panel/panel.c
index 04d86f3..8bc604d 100644
--- a/drivers/staging/panel/panel.c
+++ b/drivers/staging/panel/panel.c
@@ -2042,11 +2042,11 @@ static void init_scan_timer(void)
  * corresponding to out and in bits respectively.
  * returns 1 if ok, 0 if error (in which case, nothing is written).
  */
-static int input_name2mask(const char *name, pmask_t *mask, pmask_t *value,
-			   char *imask, char *omask)
+static u8 input_name2mask(const char *name, pmask_t *mask, pmask_t *value,
+			  u8 *imask, u8 *omask)
 {
 	static char sigtab[10] = "EeSsPpAaBb";
-	char im, om;
+	u8 im, om;
 	pmask_t m, v;
 
 	om = 0ULL;
-- 
1.9.1


^ permalink raw reply related	[flat|nested] 6+ messages in thread

* [PATCH v2 2/5] Staging: panel: Remove typedef pmask_t
  2016-01-03 19:38 [PATCH v2 0/5] Staging: panel: TODO fixes Ksenija Stanojevic
  2016-01-03 19:39 ` [PATCH v2 1/5] Staging: panel: Use u8 type Ksenija Stanojevic
@ 2016-01-03 19:40 ` Ksenija Stanojevic
  2016-01-03 19:42 ` [PATCH v2 3/5] Staging: panel: Remove ULL Ksenija Stanojevic
                   ` (2 subsequent siblings)
  4 siblings, 0 replies; 6+ messages in thread
From: Ksenija Stanojevic @ 2016-01-03 19:40 UTC (permalink / raw
  To: gregkh; +Cc: willy, devel, linux-kernel, Ksenija Stanojevic

Use __u64 instead of pmask_t and remove pmask_t since is useless.

Signed-off-by: Ksenija Stanojevic <ksenija.stanojevic@gmail.com>
---
v2: nothing

 drivers/staging/panel/panel.c | 24 +++++++++++-------------
 1 file changed, 11 insertions(+), 13 deletions(-)

diff --git a/drivers/staging/panel/panel.c b/drivers/staging/panel/panel.c
index 8bc604d..7138ee7 100644
--- a/drivers/staging/panel/panel.c
+++ b/drivers/staging/panel/panel.c
@@ -172,8 +172,6 @@ static __u8 scan_mask_o;
 /* logical or of the input bits involved in the scan matrix */
 static __u8 scan_mask_i;
 
-typedef __u64 pmask_t;
-
 enum input_type {
 	INPUT_TYPE_STD,
 	INPUT_TYPE_KBD,
@@ -188,8 +186,8 @@ enum input_state {
 
 struct logical_input {
 	struct list_head list;
-	pmask_t mask;
-	pmask_t value;
+	__u64 mask;
+	__u64 value;
 	enum input_type type;
 	enum input_state state;
 	__u8 rise_time, fall_time;
@@ -219,19 +217,19 @@ static LIST_HEAD(logical_inputs);	/* list of all defined logical inputs */
  * corresponds to the ground.
  * Within each group, bits are stored in the same order as read on the port :
  * BAPSE (busy=4, ack=3, paper empty=2, select=1, error=0).
- * So, each __u64 (or pmask_t) is represented like this :
+ * So, each __u64 is represented like this :
  * 0000000000000000000BAPSEBAPSEBAPSEBAPSEBAPSEBAPSEBAPSEBAPSEBAPSE
  * <-----unused------><gnd><d07><d06><d05><d04><d03><d02><d01><d00>
  */
 
 /* what has just been read from the I/O ports */
-static pmask_t phys_read;
+static __u64 phys_read;
 /* previous phys_read */
-static pmask_t phys_read_prev;
+static __u64 phys_read_prev;
 /* stabilized phys_read (phys_read|phys_read_prev) */
-static pmask_t phys_curr;
+static __u64 phys_curr;
 /* previous phys_curr */
-static pmask_t phys_prev;
+static __u64 phys_prev;
 /* 0 means that at least one logical signal needs be computed */
 static char inputs_stable;
 
@@ -1789,7 +1787,7 @@ static void phys_scan_contacts(void)
 	gndmask = PNL_PINPUT(r_str(pprt)) & scan_mask_i;
 
 	/* grounded inputs are signals 40-44 */
-	phys_read |= (pmask_t)gndmask << 40;
+	phys_read |= (__u64)gndmask << 40;
 
 	if (bitmask != gndmask) {
 		/*
@@ -1805,7 +1803,7 @@ static void phys_scan_contacts(void)
 
 			w_dtr(pprt, oldval & ~bitval);	/* enable this output */
 			bitmask = PNL_PINPUT(r_str(pprt)) & ~gndmask;
-			phys_read |= (pmask_t)bitmask << (5 * bit);
+			phys_read |= (__u64)bitmask << (5 * bit);
 		}
 		w_dtr(pprt, oldval);	/* disable all outputs */
 	}
@@ -2042,12 +2040,12 @@ static void init_scan_timer(void)
  * corresponding to out and in bits respectively.
  * returns 1 if ok, 0 if error (in which case, nothing is written).
  */
-static u8 input_name2mask(const char *name, pmask_t *mask, pmask_t *value,
+static u8 input_name2mask(const char *name, __u64 *mask, __u64 *value,
 			  u8 *imask, u8 *omask)
 {
 	static char sigtab[10] = "EeSsPpAaBb";
 	u8 im, om;
-	pmask_t m, v;
+	__u64 m, v;
 
 	om = 0ULL;
 	im = 0ULL;
-- 
1.9.1


^ permalink raw reply related	[flat|nested] 6+ messages in thread

* [PATCH v2 3/5] Staging: panel: Remove ULL
  2016-01-03 19:38 [PATCH v2 0/5] Staging: panel: TODO fixes Ksenija Stanojevic
  2016-01-03 19:39 ` [PATCH v2 1/5] Staging: panel: Use u8 type Ksenija Stanojevic
  2016-01-03 19:40 ` [PATCH v2 2/5] Staging: panel: Remove typedef pmask_t Ksenija Stanojevic
@ 2016-01-03 19:42 ` Ksenija Stanojevic
  2016-01-03 19:43 ` [PATCH v2 4/5] Staging: panel: Reduce value range for *name Ksenija Stanojevic
  2016-01-03 19:44 ` [PATCH v2 5/5] Staging: panel: Make code more readable Ksenija Stanojevic
  4 siblings, 0 replies; 6+ messages in thread
From: Ksenija Stanojevic @ 2016-01-03 19:42 UTC (permalink / raw
  To: gregkh; +Cc: willy, devel, linux-kernel, Ksenija Stanojevic

Remove ULL on om and im, since it's useless.

Signed-off-by: Ksenija Stanojevic <ksenija.stanojevic@gmail.com>
---
v2: leave ULL on m and v.
 drivers/staging/panel/panel.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/drivers/staging/panel/panel.c b/drivers/staging/panel/panel.c
index 7138ee7..e9641ea 100644
--- a/drivers/staging/panel/panel.c
+++ b/drivers/staging/panel/panel.c
@@ -2047,8 +2047,8 @@ static u8 input_name2mask(const char *name, __u64 *mask, __u64 *value,
 	u8 im, om;
 	__u64 m, v;
 
-	om = 0ULL;
-	im = 0ULL;
+	om = 0;
+	im = 0;
 	m = 0ULL;
 	v = 0ULL;
 	while (*name) {
-- 
1.9.1


^ permalink raw reply related	[flat|nested] 6+ messages in thread

* [PATCH  v2 4/5] Staging: panel: Reduce value range for *name
  2016-01-03 19:38 [PATCH v2 0/5] Staging: panel: TODO fixes Ksenija Stanojevic
                   ` (2 preceding siblings ...)
  2016-01-03 19:42 ` [PATCH v2 3/5] Staging: panel: Remove ULL Ksenija Stanojevic
@ 2016-01-03 19:43 ` Ksenija Stanojevic
  2016-01-03 19:44 ` [PATCH v2 5/5] Staging: panel: Make code more readable Ksenija Stanojevic
  4 siblings, 0 replies; 6+ messages in thread
From: Ksenija Stanojevic @ 2016-01-03 19:43 UTC (permalink / raw
  To: gregkh; +Cc: willy, devel, linux-kernel, Ksenija Stanojevic

out is 0-9 so it's too much for om, therefore reduce value range for
*name from '0'-'9' to '0'-'7'.

Signed-off-by: Ksenija Stanojevic <ksenija.stanojevic@gmail.com>
---
v2: nothing
 drivers/staging/panel/panel.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/staging/panel/panel.c b/drivers/staging/panel/panel.c
index e9641ea..fcfcda7 100644
--- a/drivers/staging/panel/panel.c
+++ b/drivers/staging/panel/panel.c
@@ -2065,7 +2065,7 @@ static u8 input_name2mask(const char *name, __u64 *mask, __u64 *value,
 		im |= BIT(in);
 
 		name++;
-		if (isdigit(*name)) {
+		if (*name >= '0' && *name <= '7') {
 			out = *name - '0';
 			om |= BIT(out);
 		} else if (*name == '-') {
-- 
1.9.1


^ permalink raw reply related	[flat|nested] 6+ messages in thread

* [PATCH v2 5/5] Staging: panel: Make code more readable
  2016-01-03 19:38 [PATCH v2 0/5] Staging: panel: TODO fixes Ksenija Stanojevic
                   ` (3 preceding siblings ...)
  2016-01-03 19:43 ` [PATCH v2 4/5] Staging: panel: Reduce value range for *name Ksenija Stanojevic
@ 2016-01-03 19:44 ` Ksenija Stanojevic
  4 siblings, 0 replies; 6+ messages in thread
From: Ksenija Stanojevic @ 2016-01-03 19:44 UTC (permalink / raw
  To: gregkh; +Cc: willy, devel, linux-kernel, Ksenija Stanojevic

Repace 'for' statement by strchr() function to make code more readable.

Signed-off-by: Ksenija Stanojevic <ksenija.stanojevic@gmail.com>
---
v2: use strchr().
 drivers/staging/panel/panel.c | 12 ++++++------
 1 file changed, 6 insertions(+), 6 deletions(-)

diff --git a/drivers/staging/panel/panel.c b/drivers/staging/panel/panel.c
index fcfcda7..1219ff7 100644
--- a/drivers/staging/panel/panel.c
+++ b/drivers/staging/panel/panel.c
@@ -2043,7 +2043,7 @@ static void init_scan_timer(void)
 static u8 input_name2mask(const char *name, __u64 *mask, __u64 *value,
 			  u8 *imask, u8 *omask)
 {
-	static char sigtab[10] = "EeSsPpAaBb";
+	const char sigtab[] = "EeSsPpAaBb";
 	u8 im, om;
 	__u64 m, v;
 
@@ -2053,13 +2053,13 @@ static u8 input_name2mask(const char *name, __u64 *mask, __u64 *value,
 	v = 0ULL;
 	while (*name) {
 		int in, out, bit, neg;
+		const char *idx;
 
-		for (in = 0; (in < sizeof(sigtab)) && (sigtab[in] != *name);
-		     in++)
-			;
-
-		if (in >= sizeof(sigtab))
+		idx = strchr(sigtab, *name);
+		if (!idx)
 			return 0;	/* input name not found */
+
+		in = idx - sigtab;
 		neg = (in & 1);	/* odd (lower) names are negated */
 		in >>= 1;
 		im |= BIT(in);
-- 
1.9.1


^ permalink raw reply related	[flat|nested] 6+ messages in thread

end of thread, other threads:[~2016-01-03 19:45 UTC | newest]

Thread overview: 6+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2016-01-03 19:38 [PATCH v2 0/5] Staging: panel: TODO fixes Ksenija Stanojevic
2016-01-03 19:39 ` [PATCH v2 1/5] Staging: panel: Use u8 type Ksenija Stanojevic
2016-01-03 19:40 ` [PATCH v2 2/5] Staging: panel: Remove typedef pmask_t Ksenija Stanojevic
2016-01-03 19:42 ` [PATCH v2 3/5] Staging: panel: Remove ULL Ksenija Stanojevic
2016-01-03 19:43 ` [PATCH v2 4/5] Staging: panel: Reduce value range for *name Ksenija Stanojevic
2016-01-03 19:44 ` [PATCH v2 5/5] Staging: panel: Make code more readable Ksenija Stanojevic

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).