Rainbows! Rack HTTP server user/dev discussion
 help / color / mirror / code / Atom feed
* bumping Rainbows! version requirements?
@ 2010-06-18 19:05 Eric Wong
  0 siblings, 0 replies; only message in thread
From: Eric Wong @ 2010-06-18 19:05 UTC (permalink / raw)
  To: rainbows-talk-GrnCvJ7WPxnNLxjTenLetw

Hi all,

Given our lack of current users, maintaining backwards compatibility
with old things isn't something I want to spend too much time on.

* Any objections to dropping Ruby 1.8.6 support?

  I believe most folks are on 1.8.7, and 1.9.2 adoption should go up
  with Rails 3.


* Any objections to requiring Rack 1.1.0 or later?

  Some Rails 2.3.x versions were pinned to Rack 1.0.x, but for
  the most part 1.1.0 and 1.2.1 are backwards-compatible.
  Rails 2.2.x and earlier (using Unicorn::App::OldRails)
  is actually more compatible with newer Rack versions than
  all but the latest Rails 2.3.x versions.

This is only for Rainbows!/Zbatery and will NOT affect Unicorn.

-- 
Eric Wong
_______________________________________________
Rainbows! mailing list - rainbows-talk-GrnCvJ7WPxnNLxjTenLetw@public.gmane.org
http://rubyforge.org/mailman/listinfo/rainbows-talk
Do not quote signatures (like this one) or top post when replying


^ permalink raw reply	[flat|nested] only message in thread

only message in thread, other threads:[~2010-06-18 19:47 UTC | newest]

Thread overview: (only message) (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2010-06-18 19:05 bumping Rainbows! version requirements? Eric Wong

Code repositories for project(s) associated with this inbox:

	../../../rainbows.git

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).