summary refs log tree commit homepage
path: root/rainbows.gemspec
diff options
context:
space:
mode:
authorEric Wong <e@80x24.org>2014-01-17 02:03:04 +0000
committerEric Wong <normalperson@yhbt.net>2014-01-17 08:34:29 +0000
commit3e701ee74ff29bdf5daa3249acede5a85a2b0097 (patch)
tree176888175c2b975f9a1ac1a33f0452e6b3d3bf86 /rainbows.gemspec
parent1b3e68e3eac0c3fbb2a32e4fddd26ee8a50ec627 (diff)
Internal reworking of unicorn 4.8.0 completely broke us(!).
This commit fixes things, but it means we no longer support
unicorn <= 4.7.  Sorry about that.
Diffstat (limited to 'rainbows.gemspec')
-rw-r--r--rainbows.gemspec5
1 files changed, 3 insertions, 2 deletions
diff --git a/rainbows.gemspec b/rainbows.gemspec
index 2ef91f7..e55c7de 100644
--- a/rainbows.gemspec
+++ b/rainbows.gemspec
@@ -28,8 +28,9 @@ Gem::Specification.new do |s|
   s.add_dependency(%q<kgio>, ['~> 2.5'])
 
   # we need Unicorn for the HTTP parser and process management
-  # 4.6.0+ supports hijacking, 4.6.2 fixes the chunk parser (for Ruby 2.0.0)
-  s.add_dependency(%q<unicorn>, ["~> 4.6", ">= 4.6.2"])
+  # we need unicorn 4.8.0+ since we depend on undocumented/unsupported
+  # unicorn internals.
+  s.add_dependency(%q<unicorn>, ["~> 4.8"])
 
   s.add_development_dependency(%q<isolate>, "~> 3.1")
   s.add_development_dependency(%q<wrongdoc>, "~> 1.6")