unicorn Ruby/Rack server user+dev discussion/patches/pulls/bugs/help
 help / color / Atom feed
Search results ordered by [date|relevance]  view[summary|nested|Atom feed]
						download: 
* [PATCH 0/3] last updates before 5.0 release
@ 2015-11-01  8:37  5% Eric Wong
  2015-11-01  8:37  7% ` [PATCH 2/3] gemspec: relax Ruby version requirement for old RubyGems Eric Wong
  0 siblings, 1 reply; 2+ results
From: Eric Wong @ 2015-11-01  8:37 UTC (permalink / raw)
  To: unicorn-public

Nothing significant...

Eric Wong (3):
      golf down conditional for socket activation
      gemspec: relax Ruby version requirement for old RubyGems
      doc updates

 ISSUES                     |  2 +-
 Links                      |  7 ++++---
 lib/unicorn/http_server.rb |  2 +-
 unicorn.gemspec            | 12 ++++++++++--
 4 files changed, 16 insertions(+), 7 deletions(-)


^ permalink raw reply	[relevance 5%]

* [PATCH 2/3] gemspec: relax Ruby version requirement for old RubyGems
  2015-11-01  8:37  5% [PATCH 0/3] last updates before 5.0 release Eric Wong
@ 2015-11-01  8:37  7% ` Eric Wong
  0 siblings, 0 replies; 2+ results
From: Eric Wong @ 2015-11-01  8:37 UTC (permalink / raw)
  To: unicorn-public; +Cc: Eric Wong

Older RubyGems (1.8.23.2 at least) does not seem to support
multiple version requirements for the Ruby version; so drop
the lower 1.9.3 requirement for now.
---
 unicorn.gemspec | 12 ++++++++++--
 1 file changed, 10 insertions(+), 2 deletions(-)

diff --git a/unicorn.gemspec b/unicorn.gemspec
index 23450f5..1099361 100644
--- a/unicorn.gemspec
+++ b/unicorn.gemspec
@@ -25,7 +25,11 @@ Gem::Specification.new do |s|
   s.files = manifest
   s.homepage = Olddoc.config['rdoc_url']
   s.test_files = test_files
-  s.required_ruby_version = [ '>= 1.9.3', '< 3.0' ]
+
+  # technically we need ">= 1.9.3", too, but avoid the array here since
+  # old rubygems versions (1.8.23.2 at least) do not support multiple
+  # version requirements here.
+  s.required_ruby_version = '< 3.0'
 
   # for people that are absolutely stuck on Rails 2.3.2 and can't
   # up/downgrade to any other version, the Rack dependency may be
@@ -38,5 +42,9 @@ Gem::Specification.new do |s|
   s.add_development_dependency('test-unit', '~> 3.0')
   s.add_development_dependency('olddoc', '~> 1.0')
 
-  s.licenses = ["GPLv2+", "Ruby 1.8"]
+  # Note: To avoid ambiguity, we intentionally avoid the SPDX-compatible
+  # 'Ruby' here since Ruby 1.9.3 switched to BSD-2-Clause, but we
+  # inherited our license from Mongrel when Ruby was at 1.8.
+  # We cannot automatically switch licenses when Ruby changes.
+  s.licenses = ['GPL-2.0+', 'Ruby-1.8']
 end
-- 
EW


^ permalink raw reply	[relevance 7%]

Results 1-2 of 2 | reverse results
2015-11-01  8:37  5% [PATCH 0/3] last updates before 5.0 release Eric Wong
2015-11-01  8:37  7% ` [PATCH 2/3] gemspec: relax Ruby version requirement for old RubyGems Eric Wong


unicorn Ruby/Rack server user+dev discussion/patches/pulls/bugs/help

Archives are clonable:
	git clone --mirror https://yhbt.net/unicorn-public
	git clone --mirror http://ou63pmih66umazou.onion/unicorn-public

Example config snippet for mirrors

Newsgroups are available over NNTP:
	nntp://news.public-inbox.org/inbox.comp.lang.ruby.unicorn
	nntp://ou63pmih66umazou.onion/inbox.comp.lang.ruby.unicorn

 note: .onion URLs require Tor: https://www.torproject.org/

AGPL code for this site: git clone https://public-inbox.org/public-inbox.git