unicorn Ruby/Rack server user+dev discussion/patches/pulls/bugs/help
 help / color / mirror / code / Atom feed
From: Marcelo de Moraes Serpa <fullofcaffeine@gmail.com>
To: mongrel-unicorn@rubyforge.org
Subject: AMQP and Unicorn (mq gem)
Date: Tue, 9 Nov 2010 17:57:26 +0000 (UTC)	[thread overview]
Message-ID: <loom.20101109T184430-639@post.gmane.org> (raw)

Hi all,

I'm having issues with Unicorn and connecting to 
RabbitMQ using the tmm1-amqp gem.

 I've tried lots of  approaches.

The classic initializer with Thread.new { EM.run } 
for the Rails app and even tried using 
the Qusion library. 


I've made a simple mod to Qusion for it to monkey patch 
unicorn too. 

The code looks like:


module AMQP
  def self.start_web_dispatcher(amqp_settings={})
    @settings = settings.merge(amqp_settings)
    case Qusion::ServerSpy.server_type
    when :passenger
      PhusionPassenger.on_event(:starting_worker_process) do |forked| 
        if forked
          Thread.current[:mq], @conn = nil, nil
        Thread.new { start }
    when :standard
      Thread.new { start }
    when :evented
    when :none # << HERE
      Thread.new { start }
      raise ArgumentError, "AMQP#start_web_dispatcher
 requires an argument of 
  def self.die_gracefully_on_signal
    Signal.trap("INT")  { AMQP.stop { EM.stop } }
    Signal.trap("TERM") { AMQP.stop { EM.stop } }

See the :none case? It used to be empty and return nil. 

Now it has the same behavior as the non-
evented :standard server. 

The problem is that the "server_spy" wasn't 
recognizing Unicorn. So far so 

Originally, the AMQP/Qusion conf goes into config/environment.rb

   config.after_initialize do
      Qusion.start(:user => 'guest',:pass => 'mypass') 

However, when I publish messages to the queue,
 it just isn't posted. It silently fails. 

I've then tried to put this on config/unicorn.rb:

before_fork do |server,worker|
 Qusion.start(:user => 'guest',:pass => 'mypass')

And the hey! message is posted. 

However, it only works from here, the MQ.new.queue on the app code 
fails silently.

Any ideas on what might be happenig?

Unicorn mailing list - mongrel-unicorn@rubyforge.org
Do not quote signatures (like this one) or top post when replying

             reply	other threads:[~2010-11-09 19:02 UTC|newest]

Thread overview: 3+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2010-11-09 17:57 Marcelo de Moraes Serpa [this message]
2010-11-10  0:55 ` AMQP and Unicorn (mq gem) Eric Wong
2010-11-10  2:11   ` Jordan Ritter

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:

  List information: https://yhbt.net/unicorn/

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=loom.20101109T184430-639@post.gmane.org \
    --to=fullofcaffeine@gmail.com \
    --cc=mongrel-unicorn@rubyforge.org \


* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
Code repositories for project(s) associated with this public inbox


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for read-only IMAP folder(s) and NNTP newsgroup(s).