about summary refs log tree commit
path: root/configure.in
diff options
context:
space:
mode:
authorjcoalson <jcoalson>2003-01-14 06:59:50 +0000
committerjcoalson <jcoalson>2003-01-14 06:59:50 +0000
commit1e10b29e9c1ee5949efe6dac6055d79a74fe9211 (patch)
treea0833c8e976f1a1a160c17315ce748c2a8aff632 /configure.in
parent3dbfa4fef52705ec8630c124d80889e49fd63b50 (diff)
downloadflac-arm-1.1.3-1e10b29e9c1ee5949efe6dac6055d79a74fe9211.tar.gz
add --enable-local-xmms-plugin
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 68b2d7ab..647a6f6c 100644
--- a/configure.in
+++ b/configure.in
@@ -208,6 +208,15 @@ if test x$use_3dnow = xtrue ; then
 AC_DEFINE(FLAC__USE_3DNOW)
 fi
 
+AC_ARG_ENABLE(local-xmms-plugin,
+[  --enable-local-xmms-plugin     Install XMMS plugin to ~/.xmms/Plugins instead of system location],
+[case "${enableval}" in
+        yes) install_xmms_plugin_locally=true ;;
+        no)  install_xmms_plugin_locally=false ;;
+        *) AC_MSG_ERROR(bad value ${enableval} for --enable-local-xmms-plugin) ;;
+esac],[install_xmms_plugin_locally=false])
+AM_CONDITIONAL(FLaC__INSTALL_XMMS_PLUGIN_LOCALLY, test x$install_xmms_plugin_locally = xtrue)
+
 AC_ARG_ENABLE(exhaustive-tests,
 [  --enable-exhaustive-tests      Enable exhaustive testing],
 [case "${enableval}" in