All the mail mirrored from lore.kernel.org
 help / color / mirror / Atom feed
From: Charles Keepax <ckeepax@opensource.wolfsonmicro.com>
To: cw00.choi@samsung.com
Cc: Lee Jones <lee.jones@linaro.org>,
	"myungjoo.ham@samsung.com" <myungjoo.ham@samsung.com>,
	Samuel Ortiz <sameo@linux.intel.com>,
	devicetree <devicetree@vger.kernel.org>,
	linux-kernel <linux-kernel@vger.kernel.org>,
	patches@opensource.wolfsonmicro.com
Subject: Re: [PATCH v2 2/5] extcon: arizona: Add basic microphone detection DT/ACPI bindings
Date: Fri, 19 Jun 2015 10:08:40 +0100	[thread overview]
Message-ID: <20150619090839.GT32730@opensource.wolfsonmicro.com> (raw)
In-Reply-To: <CAGTfZH1a6H4Virm-mZDeOD9Pt5M-Q13xo7v+bQwBguJuy1AJXg@mail.gmail.com>

On Fri, Jun 19, 2015 at 05:28:11PM +0900, Chanwoo Choi wrote:
> On Fri, Jun 19, 2015 at 5:17 PM, Charles Keepax
> <ckeepax@opensource.wolfsonmicro.com> wrote:
> > On Fri, Jun 19, 2015 at 11:25:57AM +0900, Chanwoo Choi wrote:
> >> Hi Charles,
> >>
> >> On Thu, Jun 18, 2015 at 11:43 PM, Charles Keepax
> >> <ckeepax@opensource.wolfsonmicro.com> wrote:
> >> > This patch adds bindings for the basic microphone detection platform
> >> > data.
> >> >
> >> > Signed-off-by: Charles Keepax <ckeepax@opensource.wolfsonmicro.com>
> >> > ---
> >> > +       dbtime = 0;
> >> > +       device_property_read_u32(arizona->dev, "wlf,micd-dbtime", &dbtime);
> >> > +       switch (dbtime) {
> >> > +       case 2:
> >>
> >> I'd like you to define the constant variable for specific integer
> >> value to improve the readability.
> >> e.g.,
> >>
> >> #define MICD_DBTIME_XXX 2
> >> #define MICD_DBTIME_XXX 4
> >>
> >> > +               pdata->micd_dbtime = 0x10000;
> >>
> >> Also, you better to define the constant variable for "0x10000" to
> >> improbe readability in the include/linux/mfd/arizona.h. If you just
> >> use the hex value, the other developer cannot analyze the meaning of
> >> "0x10000".
> >>
> >> > +               break;
> >> > +       case 4:
> >>
> >> ditto.
> >>
> >
> > I am not sure these two really warrant a define the number in DT
> > indicates the number of debounces to perform.
> >
> > #define MICD_DBTIME_TWO 2
> 
> No. I mean that you should define the appropriate name of definition
> to indicate the meaning of 2 or 4. Just not 2 -> TWO.
> 
> 2 is 2 second? or 2 is milli-second? or Is there any other meaning?
> I can never know the meaning of '2' without any description and any
> proper name of definition.

It is literally two, two debounces, I really can't see what I
could call the define. What do you think to the idea I suggested
to rename the variable dbtime -> num_debounces?

Thanks,
Charles

WARNING: multiple messages have this Message-ID (diff)
From: Charles Keepax <ckeepax-yzvPICuk2AATkU/dhu1WVueM+bqZidxxQQ4Iyu8u01E@public.gmane.org>
To: cw00.choi-Sze3O3UU22JBDgjK7y7TUQ@public.gmane.org
Cc: Lee Jones <lee.jones-QSEj5FYQhm4dnm+yROfE0A@public.gmane.org>,
	"myungjoo.ham-Sze3O3UU22JBDgjK7y7TUQ@public.gmane.org"
	<myungjoo.ham-Sze3O3UU22JBDgjK7y7TUQ@public.gmane.org>,
	Samuel Ortiz <sameo-VuQAYsv1563Yd54FQh9/CA@public.gmane.org>,
	devicetree <devicetree-u79uwXL29TY76Z2rM5mHXA@public.gmane.org>,
	linux-kernel
	<linux-kernel-u79uwXL29TY76Z2rM5mHXA@public.gmane.org>,
	patches-yzvPICuk2AATkU/dhu1WVueM+bqZidxxQQ4Iyu8u01E@public.gmane.org
Subject: Re: [PATCH v2 2/5] extcon: arizona: Add basic microphone detection DT/ACPI bindings
Date: Fri, 19 Jun 2015 10:08:40 +0100	[thread overview]
Message-ID: <20150619090839.GT32730@opensource.wolfsonmicro.com> (raw)
In-Reply-To: <CAGTfZH1a6H4Virm-mZDeOD9Pt5M-Q13xo7v+bQwBguJuy1AJXg-JsoAwUIsXosN+BqQ9rBEUg@public.gmane.org>

On Fri, Jun 19, 2015 at 05:28:11PM +0900, Chanwoo Choi wrote:
> On Fri, Jun 19, 2015 at 5:17 PM, Charles Keepax
> <ckeepax-yzvPICuk2AATkU/dhu1WVueM+bqZidxxQQ4Iyu8u01E@public.gmane.org> wrote:
> > On Fri, Jun 19, 2015 at 11:25:57AM +0900, Chanwoo Choi wrote:
> >> Hi Charles,
> >>
> >> On Thu, Jun 18, 2015 at 11:43 PM, Charles Keepax
> >> <ckeepax-yzvPICuk2AATkU/dhu1WVueM+bqZidxxQQ4Iyu8u01E@public.gmane.org> wrote:
> >> > This patch adds bindings for the basic microphone detection platform
> >> > data.
> >> >
> >> > Signed-off-by: Charles Keepax <ckeepax-yzvPICuk2AATkU/dhu1WVueM+bqZidxxQQ4Iyu8u01E@public.gmane.org>
> >> > ---
> >> > +       dbtime = 0;
> >> > +       device_property_read_u32(arizona->dev, "wlf,micd-dbtime", &dbtime);
> >> > +       switch (dbtime) {
> >> > +       case 2:
> >>
> >> I'd like you to define the constant variable for specific integer
> >> value to improve the readability.
> >> e.g.,
> >>
> >> #define MICD_DBTIME_XXX 2
> >> #define MICD_DBTIME_XXX 4
> >>
> >> > +               pdata->micd_dbtime = 0x10000;
> >>
> >> Also, you better to define the constant variable for "0x10000" to
> >> improbe readability in the include/linux/mfd/arizona.h. If you just
> >> use the hex value, the other developer cannot analyze the meaning of
> >> "0x10000".
> >>
> >> > +               break;
> >> > +       case 4:
> >>
> >> ditto.
> >>
> >
> > I am not sure these two really warrant a define the number in DT
> > indicates the number of debounces to perform.
> >
> > #define MICD_DBTIME_TWO 2
> 
> No. I mean that you should define the appropriate name of definition
> to indicate the meaning of 2 or 4. Just not 2 -> TWO.
> 
> 2 is 2 second? or 2 is milli-second? or Is there any other meaning?
> I can never know the meaning of '2' without any description and any
> proper name of definition.

It is literally two, two debounces, I really can't see what I
could call the define. What do you think to the idea I suggested
to rename the variable dbtime -> num_debounces?

Thanks,
Charles
--
To unsubscribe from this list: send the line "unsubscribe devicetree" in
the body of a message to majordomo-u79uwXL29TY76Z2rM5mHXA@public.gmane.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

  reply	other threads:[~2015-06-19  9:08 UTC|newest]

Thread overview: 35+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2015-06-18 14:43 [PATCH v2 0/5] Add basic microphone detection bindings Charles Keepax
2015-06-18 14:43 ` Charles Keepax
2015-06-18 14:43 ` [PATCH v2 1/5] extcon: arizona: Update to use the new device properties API Charles Keepax
2015-06-18 14:43   ` Charles Keepax
2015-06-19  2:14   ` Chanwoo Choi
2015-06-19  2:14     ` Chanwoo Choi
2015-06-18 14:43 ` [PATCH v2 2/5] extcon: arizona: Add basic microphone detection DT/ACPI bindings Charles Keepax
2015-06-18 14:43   ` Charles Keepax
2015-06-19  2:25   ` Chanwoo Choi
2015-06-19  2:25     ` Chanwoo Choi
2015-06-19  8:17     ` Charles Keepax
2015-06-19  8:17       ` Charles Keepax
2015-06-19  8:28       ` Chanwoo Choi
2015-06-19  8:28         ` Chanwoo Choi
2015-06-19  9:08         ` Charles Keepax [this message]
2015-06-19  9:08           ` Charles Keepax
2015-06-19 10:31           ` Chanwoo Choi
2015-06-19 10:44             ` Charles Keepax
2015-06-19 10:44               ` Charles Keepax
2015-06-19 11:03               ` Chanwoo Choi
2015-06-19 11:03                 ` Chanwoo Choi
2015-06-19 11:59                 ` Charles Keepax
2015-06-19 11:59                   ` Charles Keepax
2015-06-18 14:43 ` [PATCH v2 3/5] extcon: arizona: Convert to gpiod Charles Keepax
2015-06-19  2:36   ` Chanwoo Choi
2015-06-19  8:14     ` Charles Keepax
2015-06-19  8:14       ` Charles Keepax
2015-06-19  8:39       ` Chanwoo Choi
2015-06-19  8:39         ` Chanwoo Choi
2015-06-19  9:13         ` Charles Keepax
2015-06-19  9:50           ` Chanwoo Choi
2015-06-19  9:54             ` Charles Keepax
2015-06-19  9:54               ` Charles Keepax
2015-06-18 14:43 ` [PATCH v2 4/5] mfd: arizona: Update DT doc for new mic detection bindings Charles Keepax
2015-06-18 14:43 ` [PATCH v2 5/5] mfd: arizona: Update several pdata members to unsigned Charles Keepax

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20150619090839.GT32730@opensource.wolfsonmicro.com \
    --to=ckeepax@opensource.wolfsonmicro.com \
    --cc=cw00.choi@samsung.com \
    --cc=devicetree@vger.kernel.org \
    --cc=lee.jones@linaro.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=myungjoo.ham@samsung.com \
    --cc=patches@opensource.wolfsonmicro.com \
    --cc=sameo@linux.intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.